My mods for NFSUC

View previous topic View next topic Go down

My mods for NFSUC

Post by Ti-Sonic on Wed Mar 08, 2017 10:04 am

Hello ! Normal Smile

Other than that , everything runs great , I even managed to replace the Cadillac CTS-V for this :$ :wub: :

At the moment these are already done :

- Performance of the Lamborghini Gallardo LP-560-4
- still has problem of parts
- damage " fixed "
- autosculpt for stock wheels

Problems and solutions that I'm working on:

- Correcting the frontend
- Some parts disappear / badly aligned either in freeroam or in safehouse
- Ride height too low , the car is prone to jump and to loose control if you're going too fast / switching surfaces
- Dummies misplaced
- Shader problem ( see the front bumper )
- Reduce customization parts ( swapping the car_art for " 11_1 "
- Performance parts ( and mostly nitro ) tends to not be installed even if they'be been bought in a pack. You have to install nitro as a separate item.

I did make some progress with the hidden cars replacing the "useless" ones. I managed to fix the performance parts and the sound of the Subaru WRX STI. I swapped the values of the test car aaa_aaa_aaa_01 ( known as the UFO car ) to sub_wrx_sti.

But I don't know why , the cars seems to react different :

Gallardo : In free roam with damage activated , the whole car is lower than it should be. When the damage isn't activated , the car displays well , only the right side skirt missing , with the headlight bulbs.

350z : If the damage is activated : in freeroam most of the parts disappear , only the base , the wheels ( with brakes and rotors ) , headlights , brakelights does appear , if the damage is turned off , all parts appear.

Wrx : This car is the most bugged of all. With no damage , it shows well in freeroam , but if the damage is activated...erm... :ninja:. Most of all : any collision leads to a crash of the game.



(Image from Bytesss , on NFS Unlimited.)

I talked with Arturo about this , for him it's probably due to a bug of the game engine , which is not false considering how bugged the game is , however I have some doubts about it since most of the cars works fine with the damage activated. Maybe there is a special hash / code to enable those parts once damaged.
avatar
Ti-Sonic

Joined : 2017-02-28
Messages : 47
Location : Martinique

Back to top Go down

Re: My mods for NFSUC

Post by Ti-Sonic on Wed Mar 08, 2017 10:06 am

At least , now I can use this car without crashing the game when I enable the damage for this car :



And guess what , I only had to swap a file , the DAMAGE folder contains the damage of all the cars , and the one which belongs to the Subaru was bugged. I used the one from the Evo IX to "create" a new one.
avatar
Ti-Sonic

Joined : 2017-02-28
Messages : 47
Location : Martinique

Back to top Go down

Re: My mods for NFSUC

Post by ArturoPlayerOne on Wed Mar 08, 2017 7:17 pm

That's spectacular, man!
Good to know that you restored it!
avatar
ArturoPlayerOne
Moderator

Joined : 2016-12-31
Messages : 120
Location : Santiago, Chile

Back to top Go down

Re: My mods for NFSUC

Post by MNaeemi777 on Wed Mar 08, 2017 7:50 pm

That's natural that a modder has problems with modding of a new game. Don't worry, good luck and continue your path! Normal Smile
BTW, do engine sound files of Undercover are GIN? I heard engine sound of cars in YouTube, but they're not wonderful, IMO and I want change sounds of them.

_________________
avatar
MNaeemi777

Joined : 2017-03-01
Messages : 48
Location : Karaj, Iran

Back to top Go down

Re: My mods for NFSUC

Post by Ti-Sonic on Wed Mar 08, 2017 10:40 pm

They use the gin file extension in Vlt-Ed, but almost all the folder contains .tmx files. I think the game uses them as identifiers for the soundfiles , but I'm not sure enought about this.
avatar
Ti-Sonic

Joined : 2017-02-28
Messages : 47
Location : Martinique

Back to top Go down

Re: My mods for NFSUC

Post by ArturoPlayerOne on Thu Mar 09, 2017 9:00 pm

Maybe it's because of the game engine PS uses.
Speedy knows more about this.
avatar
ArturoPlayerOne
Moderator

Joined : 2016-12-31
Messages : 120
Location : Santiago, Chile

Back to top Go down

Re: My mods for NFSUC

Post by OutBlast on Fri Mar 10, 2017 10:37 pm

Great to see Impreza in its restored form.
avatar
OutBlast

Joined : 2017-01-06
Messages : 3

Back to top Go down

Re: My mods for NFSUC

Post by 379Felipe on Sat Mar 11, 2017 1:09 pm

Wait, you the Impreza WRX by replacing another car or added another entry in attributes.bin and fixed the model in its own car folder?

379Felipe
Researcher

Joined : 2017-01-06
Messages : 14

Back to top Go down

Re: My mods for NFSUC

Post by Ti-Sonic on Mon Mar 13, 2017 3:48 am

@379Felipe wrote:Wait, you the Impreza WRX by replacing another car or added another entry in attributes.bin and fixed the model in its own car folder?

Yup , i modified the MODEL node in pvehicle , for the AAA_AAA_AAA_01 ( UFO Cars ) , now it loads the Subaru model instead. No matter what car I would replace , the crash will be the same , and adding the necessary nodes ( copied from the Evo IX ) for the damage didn't solved the crash problem.

So I copied the damage file of the Evo , then renamed it to fit the original name of the older damage file , and it worked.


I tried with the Gallardo Superleggera wich suffered from the same issue , now when you activate the damage , the parts will be correctly placed. Before , the car body could be used , and it had a very little damage with some missing / misplaced parts.

Now I'm making a sort of " patch " to play with those hidden models. I'll try to see what happens with the 350Z. Normal Smile
avatar
Ti-Sonic

Joined : 2017-02-28
Messages : 47
Location : Martinique

Back to top Go down

Re: My mods for NFSUC

Post by 379Felipe on Mon Mar 13, 2017 8:44 am

So you tried to add new nodes in pvehicle for the cut STI and Gallardo but it didn't worked, right? When you tried replace already existing nodes in pvehicle it worked?

379Felipe
Researcher

Joined : 2017-01-06
Messages : 14

Back to top Go down

Re: My mods for NFSUC

Post by Ti-Sonic on Mon Mar 13, 2017 10:46 am

@379Felipe wrote:So you tried to add new nodes in pvehicle for the cut STI and Gallardo but it didn't worked, right? When you tried replace already existing nodes in pvehicle it worked?

I thought that parts were linked to " car_parts " node ,so I copied some of them for the models which didn't had one , or had one , but with missing elements. Unfortunately It didn't worked.

On a second sight I added the existing elements in " damageobjectspecs" ( I don't remember the name exactly ) , and I think that could have solved a part of the damage issue.

About the pvehicle , it's a node that will always work , so I knew that changing the folder name of the car in the "MODEL" value of the AAA_AAA_AAA_01 will work , but I had no idea on how to solve the damage.No Mouth

It seems that you can add the values that you want , but if the damage file of a car is bugged , it probably lacks of data for damaged cars , so it crashes the game if the model used get a collision , but swapping it with a file of a finished car , it will work like the car was finished.:shock: :lol!:

I tried with the 350Z , and now all parts which were disappearing when damage was enabled are now appearing. Happy Smile 1
avatar
Ti-Sonic

Joined : 2017-02-28
Messages : 47
Location : Martinique

Back to top Go down

Re: My mods for NFSUC

Post by Ti-Sonic on Wed Jul 05, 2017 5:22 am

BMW M3 - Most Wanted engine sound [NFSUC]

 

NFS Cars : http://www.nfscars.net/need-for-speed-undercover/10/files/view/14773/
DP : http://drivingpassion.net/site/index.php?page=downloads&type=entry&id=need-for-speed-series%2F2008-need-for-speed%2Fmisc%2Fbmw-m3-most-wanted
avatar
Ti-Sonic

Joined : 2017-02-28
Messages : 47
Location : Martinique

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum